1999 F911 PTO stops after running 10 minutes


[ Save This Page ] [ Follow Ups ] [ Post Followup ] [ John Deere Tractor Discussion Forum ] [ FAQ ]

SSB Farm Tractor Parts, Manuals & Antique TractorsAftermarket Farm & Old Antique Tractor PartsTractor Service, Repair & Owners Operators Manual ShopTractor ImplementsTractor SeatsTractor Front End LoadersPedal Toy Tractors Farm Tractors For Sale ClassifiedsAntique Tractors For Sale ClassifiedsTractors Forum - Help & AdviceTractor, Gardening, Mowers & Outdoor Equipment BooksTractor ProductsContact Us
SEARCH MANUALS
FIND PARTS
How much is your farm tractor worth? Find resale prices for tractors built from 1939 through today, with complete specifications and serial numbers. Save 15% on our Official Tractor Blue Book sale!

Search This Message Board:

1999 F911 PTO stops after running 10 minutes

Greg We have an F911 front mount mower and it has just started this. After mowing a few minutes, the blades stop and the motor bogs down. Once the blades stop completely, the motor runs fine. Any suggestions???
matt I have the same problem only my mower's PTO only runs for about a second.
Brian I have a F911 that just started shutting down the power to the mower deck. I changed the seat switch and harness without success. The deck seems to shut off after it is running awhile. The engine is not hot. You can restart the deck and it will run for a few more minutes before shutting down again. Eventually you cannot turn deck on until it sits for awhile. Any thoughts?


[ Save This Page ] [ Follow Ups ] [ Post Followup ] [ John Deere Tractor Discussion Forum ] [ FAQ ]
Post a Followup

Name:
E-Mail:

Subject:

Comments:

Email Notification: If you check this box, email will be sent to you whenever someone replies to your message. You must include your email address above to receive this notification.


[ Save This Page ] [ Follow Ups ] [ Post Followup ] [ John Deere Tractor Discussion Forum ] [ FAQ ]

Name:
Email:  

Sign Up For Our Monthly Special Sales!