Case 480 D

[ Save This Page ] [ Follow Ups ] [ Post Followup ] [ Case Tractor Discussion Forum ] [ FAQ ]

SSB Farm Tractor Parts, Manuals & Antique TractorsAftermarket Farm & Old Antique Tractor PartsTractor Service, Repair & Owners Operators Manual ShopTractor ImplementsTractor SeatsTractor Front End LoadersPedal Toy Tractors Farm Tractors For Sale ClassifiedsAntique Tractors For Sale ClassifiedsTractors Forum - Help & AdviceTractor, Gardening, Mowers & Outdoor Equipment BooksTractor ProductsContact Us
How much is your farm tractor worth? Find resale prices for tractors built from 1939 through today, with complete specifications and serial numbers. Save 15% on our Official Tractor Blue Book sale!

Search This Message Board:

Case 480 D

Shirley This Case starts ok, but after perhaps 10-15 minutes of moving hay, it starts to surge and idle rough then just quits running. If I wait for about 1/2 an hour it will start again. Also, the gauges don't work either- that just started recently. Help!! thanks
AJ Check that the tank breather is not blocked and causing a vacuum,if ok put in new fuel filters and bleed the system.

Jerry The RPM's dropped from 2000 to around 1200 with pedal to the floor and the speed is barely above a crawl. I have changed the air and primary and secondary fuel filters.
Still won't get over 1200 to 1300 RPM's.
What else coould be the problem?

Earth Mover My 480 D-LL, did the same thing several years ago. I had the injection pump rebuilt and the problem was solved.
dick Have similar problem w/ my 480C. Foung idle/cutoff cable housing had slipped under clamp( on left side of block) preventing full fuel flow. That solved it then.
Now a similar problem : machine starts and runs instantly then loses power and stops within 15 seconds, It will restart immediately, running for 7 or 8 seconds, while after 15 sec rest will run for 15 sec. Obviously a fuel flow problem.
I have:
replaced and bled both filters,
drained approx. a gallon of fuel through filters with and w/o fuel line to pump,
removed elbo fitting at pump( clean, no return line on this model)
removed screen in pump( clean)
Checked fuel level manually(2/3 full)
Cleaned air filter and run it w and w/out filter(obviously not air restricted)
I first thought water contamination but found none in sediment bulb, tank or filters??????Ideas

[ Save This Page ] [ Follow Ups ] [ Post Followup ] [ Case Tractor Discussion Forum ] [ FAQ ]
Post a Followup




[ Save This Page ] [ Follow Ups ] [ Post Followup ] [ Case Tractor Discussion Forum ] [ FAQ ]


Sign Up For Our Monthly Special Sales!