SSB Farm Tractor Parts, Manuals & Antique TractorsAftermarket Farm & Old Antique Tractor PartsTractor Service, Repair & Owners Operators Manual ShopTractor ImplementsTractor SeatsTractor Front End LoadersPedal Toy Tractors Farm Tractors For Sale ClassifiedsAntique Tractors For Sale ClassifiedsTractors Forum - Help & AdviceTractor, Gardening, Mowers & Outdoor Equipment BooksTractor ProductsContact Us
SEARCH MANUALS
FIND PARTS
How much is your farm tractor worth? Find resale prices for tractors built from 1939 through today, with complete specifications and serial numbers. Save 15% on our Official Tractor Blue Book sale!

Search This Message Board:

480c bucket valve

david hi aj
i am having intermittent problems with my bucket control in the float position. it is the 2 lever unit. for most of the winter it has worked ok, but when i got a lot of weight in the bucket or went too fast it would lift the front end off the ground. plowing snow today with the bucket in float position, it would immediatly raise the front up as soon as i started moving forward. after i while it started acting normally. also, backdragging with the bucket in float position, it works fine. thanks for the help
david

AJ Check the linkage from the levers to the valve,there are lot of clevis pins that can be worn and not pushing the valve to the float position properly,if that checks ok there may be a problem inside the valve,on the valve end opposite the lever there is a cover housing the spring that returns the valve to neutral,sometimes the bolt that holds the spring to the spool comes loose,do not work on any part of the hydraulics with the equipment raised,put the equipment on the ground and stop the engine.
AJ

david hi aj i cleaned and lubed the linkage, everything seems fine i checked that bolt inside the spool it was tight. inthe cap on the spool, theres a countersunk fitting that adjusts in and out with a allen wrench. if i adjust it in it stops the spool from going into the float position, i have adjusted it out as far as i dare. it works better but it still raises the wheels when i hit some resistance. there is a relif valve and and a check valve in the system, could they be the problem? thanks for the help


Post a Followup



Enter Code Shown Above As it Appears:
Name:  
E-Mail:  
Subject:

Upload Picture (Optional - Choose File):


Comments:

Name:
Email:  

Sign Up For Our Monthly Special Sales!