SSB Farm Tractor Parts, Manuals & Antique TractorsAftermarket Farm & Old Antique Tractor PartsTractor Service, Repair & Owners Operators Manual ShopTractor ImplementsTractor SeatsTractor Front End LoadersPedal Toy Tractors Farm Tractors For Sale ClassifiedsAntique Tractors For Sale ClassifiedsTractors Forum - Help & AdviceTractor, Gardening, Mowers & Outdoor Equipment BooksTractor ProductsContact Us
SEARCH MANUALS
FIND PARTS
How much is your farm tractor worth? Find resale prices for tractors built from 1939 through today, with complete specifications and serial numbers. Save 15% on our Official Tractor Blue Book sale!

Search This Message Board:

2290 no reverse,no 1pwrshft, no 3 pwrshft

David Grenier I just had the powershift rebuilt on my case 2290. I worked pushing snow for 5 hrs,then spools had junk in them, killed the motor, cleaned them up. Pushed snow for about 4 hours, broke a front LHS spindle that jolted the tractor somewhat. I put on the new spindle, then tractor will only go forward in 2nd powershift and it really jumps! When I try the other gears, it will try to move slightly. If I rev the engine to 1800, it will move slowly and slighty. I located a pressure gauge, plugged into hydraulics, worked the lever and it read zero, but yet the front end loader works very slow from these hydraulics. I changed filters,the suction screen is clean. When I start tractor, the red trans pressure/temp light stays on, and the yellow filter light stays on. The tractor makes kind of a moaning sound under the seat. If i step in the clutch, the lights go out for about 5 seconds, then come on again. I really need some insight, I have put a lot of money into this poor tractor I would rather not send it to the wrecker yet!
DLO Assuming that the tractor drives normally when in 2nd gear, your C-2 clutch in the power shift isn't working for some reason. If the RPS(Range Power Shift) has just been rebuilt, the transmission should be clean and if a thorough job was done, the RPS valve should have been cleaned and resealed also. If this wasn't done then its hard to tell where debris came from to stick the pilot spools in the valve. You don't mention which spools were stuck, it's a a safe bet C-3 spool was stuck simply because its always the first to stick, whatever else was stuck would give clues as to what's going on for sure. You mention that the remotes aren't working, that is probably because of a huge leak in the regulated circuit,(RPS and PTO). The regulated circuit has priority so a massive leak will prevent the hitch and remotes from working, steering and brakes have a separate pump. I would suggest hooking a gauge(at least 300 psi) to the C-2 test port on the RPS valve, the plug is 1/8 npt so its easy to adapt to, run the tractor while in 1st powershift. In 1st as well as reverse and 3rd you should see 180 to 210 psi, I'm guessing you won't, low or no pressure will indicate a leak, possibly a seal ring on C-3 clutch hub or C-2 piston, a blown gasket in the powershift valve(very rare), or a blown plastic jumper tube between the RPS valve and oil manifold for the C-3 clutch hub. If you have good pressure at C-2 test port the C-2 clutch piston could be stuck or C-2 clutch plates may be burnt up, but good pressure at C-2 wouldn't explain why your hydraulics don't work and would indicate there are other problems. Just so we aren't overlooking anything, confirm that the inching spool on the RPS valve moves up and down with the clutch pedal, with the inching spool all the way up C-2 is manually being dumped, but that situation shouldn't affect your remotes.
David Grenier DLO, Thanks for the information. I am slow at working on this problem. The mechanic who rebuilt it came around told me to remove the hyraulic pump and I have not seen him since, I was relying on his (mis?)guidance. So, best thing is to put it back on, do the proper testing and get a better idea on whats really happening. Its time learn and stopped being scared of wrecking something! The screen is clean, but I am positive he did not clean the powershift valve, RHS of transmission. I will do my best to update, its going to be slow .
David Grenier DLO,

I took a reading of the pressures taken from the rhs of tractor under the cab RPS valve. I noticed C2 vavle has zero pressure readings and also the LUB port has zero pressure readings. The others have pressure when necessary. although sometimes lower than the 180-200 psi as expected. Would a service manual be a wise investmet so I can fix this tractor on my own?

DLO A true service manual will cost a few hundred dollars from CNH. If you plan on keeping the tractor for a long time a manual is nice. For now the problem at hand is C-2 and lube. Lube pressure comes from the return oil from the power steering and brake hydraulic system(gear pump), if the tractor has no lube pressure, it won't drive in some gears due to a loss of a pressure balance in the RPS valve. Unfortunately I don't remember which specific gears it doesn't work in. If you truly have 0 psi at lube, your reverse lockout shouldn't work either. In other words with the tractor running try to pull the RPS lever from 1st to reverse without stepping on the clutch, you shouldn't be able to do it. It just occurred to me, is the inching spool (smaller of the two spools that stick out of the top of the RPS valve) working properly? The inching spool should be bottomed out in the down position with the clutch pedal up. With the clutch pedal fully depressed, the spool should move 1 1/16 inches to the up position. With the spool in the up position the valve is manually dumping C-2 clutch and lube. I've never heard of such a thing, but maybe your mechanic buddy forgot to put a cotter pin in. Even if this longshot is true you still need to get your regulated pressure up to 200-210 psi at idle, but at this point, one thing at a time.
David Grenier I checked the inching spool, all pins and linkages are good. I measured the 1 1/16 travel when clutch pedal is fully depressed. Thats all correct. Keep in mind, the tractor was fully operational for about 8 hours before it failed. Its silly, but when the spindle broke, front lhs of tractor fell and jarred the tractor, since then, all of this is happening! When I step on clutch and put tractor in gear,it only functions properly in 2nd powershift. I stomp on the brakes and there is no slipping, tractor works hard, very strong. All other shifts are basically zero. Steering works fine, brakes work.
DLO Sorry about the delay but I don't look at this site very often. The problem is still C-2 clutch. Powershift 101 basics are that there are 4 clutches in a Case powershift, it takes a combination of two clutches to make a gear. 1st is C-1, C-2, 2nd is C-1, C-3, 3rd is C-2, C-3, reverse is C-2, C-4. C-2 is the foot clutch that you modulate manually with the pedal. With the clutch all the way down C-2 is manually dumped with the inching spool, C-4 comes on at that time as a sort of transmission brake and lube is also dumped. You have no pressure in C-2 so the only gear that can possibly work is 2nd. Given what you've said, I would probably pull the powershift valve, under it there are three identical plastic tubes that go into the transmission. The tubes feed C-2, C-3, and lube. Air up each of the tubes with a blow gun, in the two clutch tubes you should feel resistance and can hear the clutch lock and unlock with air pressure. The lube will just be free flowing. The ends of the tubes are threaded so you can pull them out with a 1/2" NC bolt and pry bar. By doing this you can inspect both the tubes and the o-rings on each end. pay close attention to the gaskets on the powershift valve and don't lose the two sleeves spring and detent ball in the center of the outside and middle pieces. There's still a remote possibility of a blown gasket, I've only seen it once, but it can happen. You didn't mention if your reverse lockout was working.
David Grenier Thank you for the information. Your timing is fine, I am only intermittently working on the tractor when I get some time at night! The reverse lockout is working. Tractor running, in neutral, I cannot pull the powershift lever from 1rst to reverse. Step on clutch, then lever can move from 1rst to reverse position. I will follow your suggestions and respond when I learn more. I am not aware of any other forums for case transmissions this one/you are treating me well so far!!
David Grenier DLO, I removed the powershift block on the RHS. I took it off in one piece instead of splitting it apart. Look inside, sure enough the bottom tube had pulled out of its place. I will install new o-rings on all 3 tubes. This should be the fix I am looking for. I will confirm when complete.
David Grenier The plastic oil tube that was dislodged was the problem to my 2290, no reverse, no #1 and no #3 powershifts. Best logical description, when the front LHS spindle broke and tractor dropped, the plastic oil tube behind the powershift regulator valve dislodged. This is located on the RHS of tractor behind battery box, and behind rear tire. Thanks DLO for the help and advice.
tim earing I have a similar problem but mine is 1st, 3rd and reverse take about 5-6 seconds to engage.All gears don't slip when engaged but very difficult for running a loader or bale processer.So what I am thinking from reading this post is that I have a problem with my C-2 spool...? Any feedback would be welcome.
wayne drgac when u have the transmission in 1,2,3 range and the other shifter in 2nd it is slow to move like clutch slipping and u loose your hyd remote outlets in back , like u are dumping all ur oil to case but 1,3,4 gears are fine is it possible a valve is hung open or washed out or is it internal problem i had to unstick c2 or c3 valve last year but that is all the problems ive had please any advice would be great
Kevin On the powershift valve bottom 2nd cap/plug from the front remove with a 7/8 inch wrench a spring will pop out and to get the valve out use a screw or bolt that you find on the back of an alternator. Pull out the spool wipe off and reinsert. With the screw in the threaded in push the spool in and out until it moves easily may have to wipe off a few times and work it fully in to get the bore freed up. The symptoms I had stepped clutch down and tractor stopped no rolling free at idle in first powershift and range in neutral it caused the engine to lug 200 rpms and had no reverse. It is bottom front 2nd plug back. Another trick to free a spool is to put range in neutral and shift thru the powershift speeds over and over again if that fails take apart. Once when I stepped the clutch down the stuck spool killed the tractor and the 3rd powershift was acting up did this trick and when it freed up I was able to step the clutch without killing the tractor


Post a Followup



Enter Code Shown Above As it Appears:
Name:  
E-Mail:  
Subject:

Upload Picture (Optional - Choose File):


Comments:

Name:
Email:  

Sign Up For Our Monthly Special Sales!