SSB Farm Tractor Parts, Manuals & Antique TractorsAftermarket Farm & Old Antique Tractor PartsTractor Service, Repair & Owners Operators Manual ShopTractor ImplementsTractor SeatsTractor Front End LoadersPedal Toy Tractors Farm Tractors For Sale ClassifiedsAntique Tractors For Sale ClassifiedsTractors Forum - Help & AdviceTractor, Gardening, Mowers & Outdoor Equipment BooksTractor ProductsContact Us
SEARCH MANUALS
FIND PARTS
How much is your farm tractor worth? Find resale prices for tractors built from 1939 through today, with complete specifications and serial numbers. Save 15% on our Official Tractor Blue Book sale!

Search This Message Board:

L4330 not starting

Steve I am new to Kubota and just recently purchased a L4330 HST. It started and ran great until yesterday. After turning engine off for a few minutes i tried starting it, while it turns over well it does not fire. I am not seeing any smoke and suspect fuel issue. It has a full tank. This happened in the dark last nigh so i just left it. looking for guidance on where to start. is there a fuel soleniod fuse to check. any help would be great. Thanks
jm. Steve the fuel control solenoid does require power to make the tractor run. Thing is a TWO part device. When you turn you key to START current goes to a coil called the PULL in coil and pulls the fuel control pin. Then when you let go of the key and it goes to the RUN position current goes to another coil called the HOLD in coil. Go to the white connector there at the solenoid and check for current as you go thru the starting sequence.
Steve Thank you JM. I will try this. I looked things over last night and checked the fuel filter and it has good flow to that. I then pulled the hose off the downstream side of what looked like a solenoid to me but I didn't see any wires just a hose in and out. I had my wife turn it over and saw flow there but it was hard to tell if it was just running back from the rail. Is the solenoid downstream of the fuel filter? I also did clean up the battery terminals and gave it a jump just to verify that it was not a weak battery. by the time I get home lately it is almost dark out and its broke down in the trees. Will see if i can find that tonight.
jm. The fuel control solenoid is about the size of a flashlight battery and is mounted directly on the rear of the injector pump. NO FUEL lines near it only a three wire plug. You have to have power there to make the fuel turn on.
Steve thanks again JM. I did find the solenoid and pulled the plug to inspect wires, all looked good so I put it back on and tried it. still no luck. once my wife got home i pulled them again and tested power while she turned it over. read 9-12 volts on each. there were only 2 wires one with blue stripe and one with red stripe. not finding an issue I plugged it back in and she tried it again and it started. drove it to the shop and left it run for an hour then turned it on and off couple times and it worked fine. The wires all looked clean and it only has 500 hours. Not sure what to think. I'd feel better if I found a smoking gun. I did find the Kubota parts site drawings you refered to in other posts to verify that I was on the right solenoid. BTW it is great that people like you with your knowledge take the time out of your day to help others. THANK YOU!
jm. Pretty common loose connection, You are not the first one that had that problem. GLAD we got you going and the thanks and posting back is all I get. SO thanks for one reason it helps me help the next guy. Lots of these folks soon as the problem is fixed they never post back that what I suggested really worked. ThANKS AGAIN


Post a Followup



Enter Code Shown Above As it Appears:
Name:  
E-Mail:  
Subject:

Upload Picture (Optional - Choose File):


Comments:

Name:
Email:  

Sign Up For Our Monthly Special Sales!